SKU #F935

Polaris P935

Frequently asked questions

There is too much cable length in the water. Do not unravel the entire cable length. Place only the required length of cable in the water and place the rest on the side of the pool. Follow the procedure in "Cord Tangling" in the manual to avoid and correct tangled cord. View Video »
1. The filter canister is full or dirty. Clean the filter canister, see "Cleaning the Filter Canister" in manual. View Video » 2. Sides of pool are slippery or slimy. Although the water seems clear, microscopic algae, invisible to the human eye, are present in the pool. As a result the pool sides become slippery and prevent the cleaner from climbing. Check tires for wear and replace as necessary. Do a shock chlorination treatment and slightly reduce the pH. DO NOT leave the cleaner in the pool during this treatment.
1. There is air in the appliance casing. Submerge the cleaner following the procedure in "Submerging the Cleaner" in the manual. 2. The filter canister is full or dirty. Clean the filter canister, see "Cleaning the Filter Canister" in manual. View Video »
1. The brushes have become smooth or the "wear" indicator shows. Replace the brushes following the procedure in "Replacing the Brushes" in the manual. 2. Filter canister is full or dirty. Clean the filter canister following the procedure in "Cleaning the Filter Canister" in the manual. 3. Make sure the floating cable is spread out over the pool. Ensure the cable is not too tightly wrapped or coiled when storing. If the problem persists, lay the cable straight in the sun to relax it and remove kinks. View Video »
1. Unplug floating cable from the control unit and reconnect. 2. Remove cleaner from the pool and re-submerge, see "Submerging the Cleaner" in the manual. 3. Propellor or wheels may be jammed and not turning correctly. Contact Polaris Technical Support at (USA) 1-800-822-7933 or (Canada) 1-888-647-4004.
Cleaner may be sucking air (lights will appear after 60 seconds air intake). Remove cleaner from the pool and re-submerge, see "Submerging the Cleaner" in the manual.
1. The outlet, the control unit is connected to, is not supplying electrical power. Check that the outlet to which the control unit is connected is receiving electricity. 2. Check that you have started one (1) of the two (2) programs and check that the indicator for the selected program is lit. If the indicator light is not lit, turn the wheels then disconnect the control unit and wait at least 20 seconds before reconnecting. If the problem persists, contact Polaris Technical Support at (USA) 1-800-822-7933 or (Canada) 1-888-647-4004.